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1 Introduction 
 

This document describes in detail the methods of backing up AxiBatch data and the 

restoration of AxiBatch data.  This applies to Versions 4. 

 

 

1.1 Definitions 

 

 

BACKUP  The method of creating a compressed version of the 

database. This normally is about a tenth of the normal 

database size. 

 

RESTORE  The method of restoring a compressed version of the 

database. 

 

ICON  Small square button which only shows an image 

 

 

INSTALLATION DIRECTORY  Directory Path where AxiBatch, AxiConsole or 

Invoicer are installed 
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2 AxiBatch 
 

2.1 AxiBatch File Path Settings 

 

The AxiBatch installation directory will always be “C:\Program Files (x86)\Axion 

Control Systems\AxiBatch”. The main executable file (AxiBatch.exe) is stored in the 

Installation Directory. 

 

When AxiBatch is installed and run for the first time it creates by default the 

following data directories if they haven't been created. 

 

22..11..11  DDaattaabbaassee  LLooccaattiioonnss  

 

The Server Path is the path for the main AxiBatch and Completed Loads databases, 

and by default is set to C:\AxiBatch Data\Databases directory. 

 

C:\AxiBatch Data\Databases\AxiBatch.gdb – the Main AxiBatch database that stores 

Orders, Bin setups, Customers, recipes and pricing etc. 

 

C:\AxiBatch Data\Databases\CompOrders.gdb – the Completed Loads database that 

stores all the completed loads and orders and stock entries. 

 

The following is where you dictate the Path of the Databases and Settings 

 
C:\AxiBatch Data\Backups – Directory where you can store database backups 
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C:\AxiBatch Data\Settings – Directory where the latest settings are backed and where 

an xml file (AxiBatchDefaultSettings.xml) is created to compare against a possible 

corruption.  

 

If a mismatch is detected, then AxiBatch will attempt to automatically restore 

“AxiBatchConsfig.config” setting file. This file is set whenever you leave the Settings 

page, so should normally never be corrupted. When this happens the docket number 

will be out of sorts, so restarting AxiBatch should sort this out. 

 

 

22..11..22  DDoocckkeett  PPaatthh  SSeettttiinnggss  

 

Docket File Pathname is the location of the docket and its filename. AxiBatch creates 

a directory by default called C:\AxiBatch Data\Docket for docket storage. 

 

C:\ AxiBatch Data\Docket\Docket.docx - Working Version of Docket Form 

 

AxiBatch uses a word document for it's docket. This file is located in the installation 

directory and is named "DOCKET.doc". 

 

You can copy this file and paste it somewhere else manually. DO NOT DELETE IT! 
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22..11..33  LLoogg  FFiillee  PPaatthhss  

 

 

C:\ AxiBatch Data\Log Files\Activity – Location of AxiBatch Activity Log Files 

C:\ AxiBatch Data\Log Files\Alarms – Location of AxiBatch Process Alarm Log Files 

C:\ AxiBatch Data\Log Files\Errors – Location of AxiBatch Errors Log Files 

 

A file is generated as follows (new one created every day) 

 

ActivityLogYYYYMMDD.csv 

AlarmLogYYYYMMDD.csv 

ErrorLogYYYYMMDD.csv 

 

where YYYY = Year 

where MM = Month 

where DD = Day 

 

You can view these files in AxiBatch using  

View->Activity Log Files 

View->Alarm Files 

 

You can also view these files using Excel or Notepad. 
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22..11..44  BBaacckkuupp  OOppttiioonnss  

 

Check “Auto Backup on Exit” to enable the auto backups when AxiBatch exits. 

Prompt Me, checked will ask the operator whether to perform the backup or not. 

Add Time Date Stamp, should be checked, to avoid replacing a corrupted database. 

This will add a date and time to the end of the database filename. 

 

Keep up to is the number of days you wish to keep in the backup directory. Anything 

older than this will be deleted to keep the memory available in reasonable order. 

 

There are two separate paths you can backup to, one should be an external server or 

network hard drive, the other could be the backup AxiBatch Computer. 

 

 

Check the Backup Full Directory, to backup the database files in the same name. This 

could be used to backup the files to a backup AxiBatch computer. 
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2.2 Restoring AxiBatch 

 

The following section describes what is required to restore all the database files and 

settings to AxiBatch running on a new computer. 

 

22..22..11  RReessttoorree  SSeettttiinnggss  

 

1. Start AxiBatch  

2. Log in using Technician User 

3. Select Tools->Restore->Plant Settings 

4. Select the settings file you have previously backed up, it can be named 

anything for example it may have the date and time stamp attached to it 

5. Restart AxiBatch 

6. Make a note of where the Database Server location path is 

 

 

22..22..22  RReessttoorree  DDaattaabbaasseess  

 

1. AxiBatch is shut down for this 

2. In Explorer, manually copy the latest backup database, it could have a date and 

time stamp after it, e.g. AxiBatch_20180206_1256.gdb (hence this was backed 

up on the 6th of Feb, 2018 at 12:56pm), into the C:\AxiBatch Data\Databases 

directory (or wherever the Database Server location path is). Do the same with 

the completed Loads database, e.g. CompOrders_20180206_1256.gdb. 

3. Change the AxiBatch database name to AxiBatch (I.e. manually remove the 

data time stamp) 

4. Change the Completed Loads database name to CompOrders.gdb (I.e. 

manually remove the data time stamp) 

5. Start AxiBatch 

6. Go to the Settings->Database and press the Test Button to check the Database 

 

 

22..22..33  RReessttoorree  tthhee  DDoocckkeett  

 

1. Copy the backed-up docket, e.g. Docket_20180206_1256.doc to the docket 

location, most likely to be the default C:\AxiBatch Data\Dockets 

2. Rename the Docket to what ever you like or to the same name that is in the 

Settings 
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3 Console 
 

3.1 Introduction 

 

This section describes restoring the data the way it was, if installing AxiBatch on a 

new computer. 

 

3.2 Console Settings Backup 

33..22..11  TToo  mmaannuuaallllyy  bbaacckkuupp  sseettttiinnggss  

 

1. Select File->Save Settings 

2. In the dialog, set the filename and path location. The type should always be 

(*.config) 

 

 

33..22..22  AAuuttoo  BBaacckkuupp  oonn  EExxiitt  

Go to Settings->Console Setup->Backup 

 

 

Check “Auto Backup on Exit” to enable the auto backups when AxiBatch exits. 
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Prompt Me, checked will ask the operator whether to perform the backup or not. 

Add Time Date Stamp, should be checked, to avoid replacing a corrupted database. 

This will add a date and time to the end of the database filename. “Keep up to” is the 

number of days you wish to keep in the backup directory. Anything older than this 

will be deleted to keep the memory available in reasonable order. 

 

There are two separate paths you can back up to, one should be an external server or 

network hard drive, the other could be a USB Stick or another external computer. 

 

 

3.3 Console Settings Restore 

 

To restore settings in Console,  

 

1. Login to Console (minimum Level 2 required) (if it is not connected to a 

database, you should login using the Technician or Administrator user level) 

2. Locate the latest settings file and select it and press Open 

3. Once done, File Exit Console, then restart it 
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4 Invoicer 
 

4.1 Introduction 

 

This section describes backing up and restoring the data for Invoicer the way it was, if 

installing Invoicer on a new computer. 

 

 

4.2 Invoice Paths 

 

44..22..11  MMaasstteerr  DDaattaabbaassee  LLooccaattiioonn  

 

 
 

Master Invoice Database Path, is the path for where the Master Invoice Database is 

located. Multiple Invoice software’s can point to this same software. 

 

The Master database will store the following tables, Plant Path information, Paths for 

Invoice Databases, Accounts, Users, and User Allocations to Databases. It does not 

store invoices that are generated. 

 

Use the “Test Database Connection” to test the Master Database. 
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If “Enable Multiple Invoice Databases” is checked then the “Invoice Database 

Locations” table in the Master Database stores the location of the multiple Invoice 

Databases. This table is found by selecting Master Database->Invoice Database 

Locations. If this is not checked, then there is only 1 Invoice database called 

“Invoice.fdb” and is stored in the same directory as the Master database called 

“Master.fdb”. 

 

 

44..22..22  LLooccaattiioonn  ffoorr  SSeettttiinnggss  aanndd  LLiissttss  

 

This is the path where settings, export lists are stored. By default, it is usually 

“C:\AxiBatch Data\Invoices\Settings”. An export list, is a list that defines how your 

invoices are exported to your accounting package. 

 

 

44..22..33  LLooccaattiioonn  ooff  tthhee  AAxxiiBBaattcchh  MMaasstteerr  DDaattaabbaassee  

 

This is the path where the AxiBatch Master database resides if it is used. 

This allows you to access Customers from the Master Database in Step 2 and Step 4. 
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44..22..44  LLooccaattiioonn  ooff  tthhee  BBaacckkuupp  OOppttiioonnss  

 

This is where you store the location of where backups are stored in. It is 

recommended that this enabled and the locations are other servers or externals drives 

and that add Date and Time Stamp are checked. 

 

 

What is backed up? 

 

1. Settings File 

2. Export Lists 

3. Master Database 

4. Invoice Database(s) 

 

These files are backed up when you exit Invoicer. 

 

Master Invoice Database Location Path is entered in here again if the location of the 

Master Database is from a remote computer. Here you enter the mapped drive name 

of the database.  
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44..22..55  LLooccaattiioonn  ooff  IInnvvooiiccee  PPDDFF  ffiilleess  

 

 
 

PDF Path – Location of where all invoices that are converted to pdf are stored. 

 

PDF TEST Path – Location of where invoices that are set for review are stored (This 

is done in Step 5 when the “Run as Test (PDF Only)” is checked, and will not print or 

email invoices, but will just create PDF’s in this directory and will not update the 

from Invoice number) 
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44..22..66  PPaatthh  ffoorr  GGeenneerraattiioonn  RReessuullttss  

 

 
 

Default Path for Generation results. This is optional at the end generation, and results 

will be saved to this location. 
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44..22..77  PPaatthh  ffoorr  IInnvvooiiccee  LLooggoo  

 

 
 

Company Logo location for Invoicer. This logo will appear on your invoice. 
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44..22..88  EExxppoorrtt  FFiilleess  LLooccaattiioonn  

 

 
 

This is the location of where you exported files are stored. You would then point your 

accounting package to import them from this location. 
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44..22..99  LLooccaattiioonn  ooff  SSYYBBIIZZ  aauuttoollooaadd  ffiilleess  

 

This is only used if you are using the Sybiz accounting package. 

 

 
 

“Directory of the Clean AutoLoad.dbf file” is the location of the empty database file 

that replaces the previously generated one, once a new export is done. 

 

“Directory location of the Generated AutoLoad.dbf file” is the location of where the 

exported file is created. Sybiz Accounting will import from this location. 
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4.3 Restoring Invoicer 

 

If Invoice is installed on another computer and you need to restore … 

 

 

44..33..11  RReessttoorree  SSeettttiinnggss  

 

1. Login in as a Technician 

2. Select File->Restore Settings 

3. Locate the last backed up settings file for Invoicer 

4. Press Open 

5. Restart Invoicer 

 

 

44..33..22  CCooppyy  DDaattaabbaassee  ttoo  tthheeiirr  LLooccaattiioonnss  

 

If the Master Database is not on a server and was always on the local computer, then 

you will need to copy the latest Master database to the directory pointed in Settings-

>Database->Master Invoice Database Path. This database is called “Master.FDB” but 

may be backed up as “Master YYMMDD_HHmm.FDB” where YY is the year, MM 

is the Month, DD is the day, HH is the hour and mm is the minute. 

 

The Invoice Database is usually located in the same directory as the Master database, 

unless you have enabled “Enable Multiple Invoice Databases”. 

 

If you have multiple Invoice Databases, then each Database may need be manually 

copied to their appropriate locations and especially if they are located on the new 

computer you are restoring to. 

 

 

44..33..33  RReessttoorree  tthhee  EExxppoorrtt  LLiissttss  

 

 

Manually copy the export list(s) to the location as set by settings. (Settings-

>Database). These files will usually have the name of the accounting package with a 

date and time stamp attached to the end of it. The extension is “.lst” and may come as 

a pair. 

 

E.g. MYOBDetails_20180320_1149.lst and MYOBHeaders_20180320_1149.lst. 

Make sure you rename them by removing the date and time stamp. 
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Here is a possible list: 

 

MYOBDetails.lst 

MYOBHeaders.lst 

QuickbooksDetails.lst 

QuickbooksHeaders.lst 

SagePastelDetails.lst 

SagePastelHeaders.lst 

SybizDetails.lst 

SybizHeaders.lst 

UniversalDetails.lst 

UniversalHeaders.lst 

XeroDetails.lst 

XeroHeaders.lst 

 

You only need to copy the Header and Details files to the accounting package you are 

using. 

 

 

44..33..44  RReessttoorree  tthhee  CCoommppaannyy  LLooggoo  

 

Manually copy the Invoice Logo to the location in Settings->Invoices-Invoice Layout-

>Header 
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5 AxiSoft 
 

5.1 Location of AxiSoft Backup Settings File 

 

The location of where the AxiSoft Settings are stored is in AxiSoft->Settings->File 

Paths->AxiSoft Settings File Backup Path. 

 

 
 

In this directory the backup will be formatted as such… 

 

AxiSoftSettings_YYYYMMDD_HHmm.config. 

 

Where YYYY = year, MM = month, DD = day, HH = hour, mm = minute. 

 

AxiSoft will automatically delete settings that are older than 60 days. 

 

5.2 Manually saving the AxiSoft Settings 

 

You can also manually save your settings using File->Save Settings, and then 

selecting your own file name. The file should be saved as a “Config” type. 
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5.3 Restoring AxiSoft Settings 

 

You will need to log in at least as an Administrator (Level 2) to be able to restore 

settings. 

 

To restore settings, select Tools->Restore->Settings from the menu. 

Select the File to restore. 

 

Shutdown AxiSoft and Restart! 

 

 

 


